Установить отбор в форме списка программно (управляемые формы)

21 Mar
Published by Nicholas
&НаСервере
Функция ПроверитьРоль(Роль)
	
	Возврат РольДоступна(Роль);
	
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	Если ПроверитьРоль("Лаборант") Тогда
		
		ГруппаОтбора = Список.Отбор.Элементы.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
		ГруппаОтбора.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИЛИ;
		
		ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		ЭлементОтбора.Родитель = ГруппаОтбора;
		ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("СтатусАнализа");
		ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
		ЭлементОтбора.Использование = Истина;
		ЭлементОтбора.ПравоеЗначение = ПредопределенноеЗначение("Перечисление.СтатусАнализа.ВРаботе");
		ЭлементОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
		
	КонецЕсли;
	
КонецПроцедуры

Tags 

1С 8.3

Добавить комментарий

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Строки и абзацы переносятся автоматически.
CAPTCHA
Вы человек или автоматическая спам-рассылка?
Target Image