D2 стразование

Как получить значение перечисления по имени или синониму?

28 Feb
Published by Nicholas

// Возвращает значение перечисления или Неопределено
//
Функция ВернутьЗначениеПеречисления(ВидПеречисления, ЗначениеТекст)

   
ЗначениеПеречисления = Неопределено;

    Для Каждого
ТекЗначение Из Метаданные.Перечисления[ВидПеречисления].ЗначенияПеречисления Цикл
        Если
ТекЗначение.Имя = ЗначениеТекст Или ТекЗначение.Синоним = ЗначениеТекст Тогда
           
ЗначениеПеречисления = Перечисления[ВидПеречисления][ТекЗначение.Имя];
            Прервать;
        КонецЕсли;
    КонецЦикла;

    Возврат
ЗначениеПеречисления;

КонецФункции

Тэги 

Добавить комментарий

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Строки и абзацы переносятся автоматически.
CAPTCHA
Вы человек или автоматическая спам-рассылка?
Target Image