D2 стразование

Сведения о внешней обработке: Дополнительный отчет

22 Sep
Published by Nicholas

Универсальные функции для модуля дополнительных внешних отчетов (1С 8.3, управляемые формы).

Функция СведенияОВнешнейОбработке() Экспорт

   
ИмяОтчета = ЭтотОбъект.Метаданные().Имя;
   
Синоним = ЭтотОбъект.Метаданные().Синоним;
   
Синоним = ?(ЗначениеЗаполнено(Синоним), Синоним, ИмяОтчета);

   
РегистрационныеДанные = Новый Структура;
   
РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
   
РегистрационныеДанные.Вставить("Наименование", Синоним);
   
РегистрационныеДанные.Вставить("Версия", "1.1");
   
РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
   
РегистрационныеДанные.Вставить("Информация", "Отчет " + Синоним);

   
ТаблицаКоманд = ПолучитьТаблицуКоманд();

   
ДобавитьКоманду(ТаблицаКоманд, Синоним, "СформироватьОтчет", "ОткрытиеФормы", Истина);

   
РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);

    Возврат
РегистрационныеДанные;

КонецФункции

Функция
ПолучитьТаблицуКоманд()

   
Команды = Новый ТаблицаЗначений;
   
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
   
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
   
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
   
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
   
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

    Возврат
Команды;

КонецФункции

Процедура
ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор = "ПечатьMXL")

   
НоваяКоманда = ТаблицаКоманд.Добавить();
   
НоваяКоманда.Представление = Представление;
   
НоваяКоманда.Идентификатор = Идентификатор;
   
НоваяКоманда.Использование = Использование;
   
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
   
НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Тэги 

1С 8.3

Добавить комментарий

Plain text

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Строки и абзацы переносятся автоматически.
CAPTCHA
Вы человек или автоматическая спам-рассылка?
Target Image